Chapter 1
Getting Acquainted with Flash 8

In This Chapter

Introducing Flash

Figuring out what you can create with Flash 8
Knowing when not to use Flash 8

Perusing the screen

Using Help

Creating your first animation

Closing Flash

Once upon a time in a galaxy that seems far, far away by now, there was
the Internet, which contained only plain, unformatted text. Then came
the Web, and we gained text formatting and graphics. Then the Web grew up
a little, and Web page graphics got fancier with things like small animations in
banner ads. But people, being used to movies and TV, wanted an even more
animated and interactive Web experience. Along came Flash.

Flash, from Macromedia, Inc., is the software that runs some of the coolest
Web sites around. When you surf the Web and see sites that contain anima-
tion across the entire page or buttons that do spectacular stunts when you
click them, you're probably seeing some Flash magic. If you create a Web site,
you can use Flash to rev up the basics and actively respond to users’ choices
so that your viewers will say, “Wow!”

In this chapter, you find out what Flash is all about, what the Flash screen
looks like, and how to use Help. Then you create your first, simple animation
so that all the rest of this book makes sense.
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Discovering Flash

Flash offers a powerful system for creating animation for the Web. In a nut-
shell, here’s an overview of how you use the system:

1. Create a Flash movie by creating graphics and animating them over
the duration of the movie.

2. Use the Publish command within Flash to publish the movie into a
Flash Player file that a browser can display.

At the same time, Flash creates the appropriate HyperText Markup
Language (HTML) code that you need for your Web page.

3. Insert HTML code into your HTML document that references the Flash
Player file.

It’s similar to adding a graphic to a Web page. Or, you can use the HTML
code alone as a new Web page for a fully Flashed page.

4. Upload the new or edited HTML document and the Flash Player file to
the location where you keep other files for your Web pages.

5. Open your browser, navigate to your Web page, and presto! — there’s
your cool animation on your Web page.

You need the Flash Player to see the effects that Flash creates. These days,
the Flash Player comes installed with most computer systems and browsers,
so most people can view Flash-driven Web sites immediately without any spe-
cial download or preparation. When you display a Web site that contains
Flash effects, your system uses the Flash Player to play the animation. Users
who don’t have a Flash Player can download it for free from Macromedia at
www.macromedia.com/go/getflash.

Web sites are getting more and more sophisticated. By using animation, spe-
cial effects, and interactive techniques, you can distinguish your Web site
from the also-rans. Creating animation isn’t hard, and you don’t have to be a
professional graphic artist, either. Anyone can create simple animations to
enhance a Web site; it just takes a little time.

To find the most up-to-date Web sites that use Flash, check out the
Macromedia site at www.macromedia.com/software/flash/flashpro and
click the Showcase button. Don’t get discouraged by seeing some of the truly
professional results at these sites. You can start with a simple, animated site
and go from there. (Chapter 16 lists ten great Flash designers and where you
can find their work.)
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Understanding What You
Can Create with Flash 8

You can use Flash 8 to create simple animation to add to your Web page. Or,
you can create an entire Web page or site using Flash and incorporate text,
graphics, interactive buttons, and animation. You can even program applica-
tions in Flash.

This book helps you use Flash to create a simple or complex Web site. The
following list describes some ways that you can manipulate text, graphics,
and sound by using Flash 8:

1 Create still or animated text on your Web page. You can choose to stop
the animation after a few seconds or repeat it while your viewers view
the page.

+” Use Flash tools to create your own graphics for your Web page or to
import graphics. You can lay out an entire Web page graphically or add
graphics to only a part of a Web page.

+ Animate graphics and make objects appear and disappear by using
the transparency feature. Objects can move, get bigger or smaller, or
rotate. Flash also lets you morph — that is, transform — shapes into new
shapes.

v~ Fill shapes and text with gradients, which are colors that gradually
change into new colors. You can even fill shapes and text with bitmap
images that you import into Flash. For example, you could fill the letters
of your name with dozens of flowers. (You aren’t a flower child any more?)

1 Create Web page buttons that not only lead your viewers wherever
you want them to go but also change shape or color at the same time.
You can make buttons change when you pass your mouse over them.
People who view your page can click a button to display a movie (anima-
tion) or start a small application.

v+ Add sound or video to your movie. It’s easy to add sound effects in
Flash. You can control how long the sound or music plays and whether
it loops to play continuously. You can play video files as well.

1 Create menus that viewers can use to navigate your site. You can create
navigation tools as well as forms, check boxes, and other interface ele-
ments that look a lot more stylish than plain HTML ones.

As you can see, you can go far with Flash if you want. And why not? It’s
great fun!
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Determining When Not to Use Flash 8

If Flash 8 is so wonderful, why doesn’t every Web site designer use it? Why
aren’t most Web sites created completely with Flash?

Here’s the other side of the story.

Although the vector graphics and animation of Flash load quickly, they don’t
load as quickly as plain text and simple graphics. Adding a movie to your
Web page creates some overhead. There’s no point in using Flash if you want
simple pages consisting of mostly text and a few graphics that you want to
stay put and not move.

You can create certain graphic effects more easily by using bitmap graphics.
Painted brushstroke and textured effects are examples. Artists create these
types of graphics by using graphics editing software, and the results are
bitmaps. Similarly, to add photographs to your Web page, you need to scan
the photographs as bitmaps. Flash creates vector graphics (defined mathe-
matically), which are different from bitmap graphics (defined by lots of dots).
You can find out more about bitmap and vector graphics in Chapter 2.

If you want simple animation, such as a few blinking dots or a marquee effect,
animated GIFs (the animated bitmap graphics that you often see on the Web)
might be smaller than Flash movies, so they load faster. You can create ani-
mated GIFs by using animated GIF editing software.

Some sites don’t lend themselves to animation. Animation can distract from
your content, and overdoing animation can make a serious site seem silly.
Animation is great, but it has its place. Also, although Flash has some fea-
tures that allow accessibility for people with disabilities, it still isn’t as acces-
sible as plain HTML. You need to determine whether animation is right for
your Web site.

Flash provides little in the way of 3-D graphics or animation. For those, you
need to go to more sophisticated software, such as Poser or 3D Studio Max.
(See Chapter 14 for more 3-D possibilities in Flash.)

Getting the Right Start

Well begun is half done, as the saying goes. The easiest way to begin using
Flash 8 is with a shortcut or alias right on your desktop. Double-click the
Flash icon, and you’re on your way. (See Appendix A for information on
installing Flash.)
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Starting Flash on a PC

Whether you installed Flash from the CD or by downloading it from the
Macromedia Web site onto your PC, you might or might not have a shortcut
on your desktop. To create one, choose Start=>Programs=>Macromedia>
Macromedia Flash 8. Right-click the Macromedia Flash 8 item and choose
Create Shortcut from the pop-up menu that appears. The new shortcut
appears on the menu. Drag that shortcut to your desktop.

To rename the shortcut, click the shortcut on your desktop. Then click the
text beneath the icon. Type Flash 8 (or whatever you want) and press Enter.
Just double-click the icon to open Flash.

Starting Flash on a Mac

You might find it handy to add the Flash 8 icon to your Dock for easy launch-
ing. To do this, click the Finder icon on the extreme left of the Dock to bring
up a new Finder window. Navigate in the Finder window to the Applications
folder, and in the Applications folder, double-click the Macromedia Flash 8
folder to open it. Click and drag the Flash 8 application icon to the Dock. A
copy of the Flash 8 application icon appears on the Dock.

Creating a new movie

Files that you create by using Flash are commonly called movies. When you
start Flash, the startup screen appears (by default). In the Create New sec-
tion, click Flash Document. If you have already opened a movie and have the
menus available, choose Filem=>New. In the New Document dialog box, select
Flash Document on the General tab and then click OK. You usually start by
creating or importing some graphics. (To find out more about working with
graphics, see Chapter 3.)

Opening an existing movie

If you want to work on a movie you've already created, when you first open
Flash, choose the movie from the Open a Recent Item section or choose Open
to find the file. If you've already opened a movie and have the menus avail-
able, press Ctrl+O (Windows) or 38+0 (Mac) or choose File>Open; then
double-click the movie to open it. The first frame appears on your screen,
and you can edit the movie any way that you want.
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When you open more than one movie, you see a tab at the top for each movie.
You can click the tabs to move from movie to movie. The tabs appear in the
order you created or opened the movies.

Taking a Look Around

|
Figure 1-1:
The Flash
screen.

If you've never created animation, the Flash screen is different from the
screens in other programs that you might be used to, so take the time to get
to know it. You can also customize the Flash screen. Figure 1-1 shows one

possible display.

If your screen opens with several rectangular panels strewn about the screen
or docked on various sides, don’t worry about them now. We explain how to
open and use these panels throughout this book, but you don’t need them for
this chapter. If they drive you crazy, right-click (Windows) or Control+click
(Mac) each panel’s title bar and choose Close Panel Group from the menu
that appears.

See Appendix B for a full layout of each panel and toolbar.
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Tooling around the toolbars

Flash contains two toolbars in the Mac version: the Edit bar and the Controller.
In Windows, Flash also offers the Main toolbar. To display or hide these tool-
bars, choose Window=>Toolbars and click the toolbar that you want to display
or hide. Here is a description of the toolbars:

»* Main toolbar (Windows only): Contains commonly used commands.
Many of these are familiar from the Standard toolbar in other Windows
programs. By default, Flash does not display the Main toolbar.

1 Controller: Lets you control the playback of movies. For more informa-
tion, see Chapter 9.

v~ Edit bar: Helps you work with the Timeline and appears at the top of the
Timeline. It includes a toggle to display and hide the Timeline, a button
for editing scenes, and a zoom control. We discuss the Timeline briefly
later in the chapter. For more information about the Timeline and
scenes, see Chapter 9.

Using panels

Panels give you access to the many Flash settings. You access the panels
from the Window menu. We discuss the specific panels throughout this book.
In this section, we explain how to keep control over your panels.

Most panels are dockable, which means that they can sit at the side or
bottom of your Flash window without covering up your work. You can also
stack them on top of each other. You control panels by doing the following:

v To dock a panel: Drag it to the side or bottom of your screen.

v To undock a panel: Drag it from its grabber, which is at the left edge of
its title bar.

+” To open or close a panel: Choose it from the Window menu.
1 To close an undocked panel: Click its Close button.

1 To close a docked panel: Right-click (Windows)/Control+click (Mac) its
title bar and choose Close Panel.

You can stack panels just like you stack plastic containers in your refrigera-
tor. Drag a panel (by its grabber) beneath another panel to stack it. You can
also collapse or expand panels: A collapsed panel displays only its title bar,
so it doesn’t take up much space. Use the arrow on the left side of the title
bar to collapse or expand a panel or click its title bar.

15
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In Windows only, the Flash interface has new arrow buttons above panels that

are docked at the bottom of your screen and to the left of panels docked at the
right. Click an arrow to collapse the panels to just the tiny arrow button. Click

the arrow again to expand the panels to their previous display.

The Tools panel contains all the tools that you need to draw and edit objects.
At the bottom of the Tools panel are options that modify how the tools func-
tion. (See Chapters 3 and 4 for a complete description of the Tools panel.)

The Property inspector is another important panel. This panel displays infor-
mation about selected objects, such as size, name, and location. You can
modify objects in the Property inspector as well. It is context-sensitive, which
means that its contents change according to what you’re doing. For example,
if you select a graphic object, the Property inspector provides settings relat-
ing to that object, and you can use the Property inspector to edit that object.

For the best in customization, you can save any layout of panels you like. Set
up the panels and choose Window=>Workspace Layout=>Save Current. In the
Save Workspace Layout dialog box that opens, give the layout a name and
click OK. To restore that layout at any time, choose Window=>Workspace
Layout and choose your very own layout.

Discovering the Flash menus

Most drawing functions are available only in the Tools panel. Similarly, you
often use the Timeline, as we discuss in the section “Following a timeline,”
later in this chapter, for creating animation. Almost every other function in
Flash is on a menu somewhere. You just need to find it. In general, we discuss
the specific menu functions where appropriate throughout this book. Table
1-1 offers a brief overview of the menus.

Table 1-1 Flash Menus
Menu What It Does
Flash (Mac only) Enables you to set preferences, create keyboard

shortcuts, and quit Flash.

File Enables you to open and close files; save files; import and
export files; print; publish movies for the Web; send a movie as
an e-mail attachment (Windows only); and quit Flash.

Edit Provides commands that let you undo and redo actions; cut,
copy, and paste to and from the Clipboard; delete, duplicate,
select, and deselect objects; find and replace; copy and paste
entire frames on the Timeline; edit symbols (see Chapter 7 for
the whole story on symbols); set preferences (Windows only);
and create keyboard shortcuts for commands (Windows only).
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Menu What It Does

View Helps you get a better view by letting you zoom in and out; show
or hide various parts of the screen; and view a grid for easy
layout.

Insert Enables you to insert symbols (Chapter 7 explains this topic);

insert and delete Timeline features, such as frames and
keyframes (see Chapter 9 for more); insert layers (check out
Chapter 6); add Timeline effects (see Chapter 9); and add
scenes (also in Chapter 9).

Modify Helps you modify symbols, shapes, frames, Timeline effects,
scenes, or the entire movie. Offers tools for transforming, align-
ing, grouping, and ungrouping objects, and breaking objects

apart.
Text Enables you to format text and check spelling.
Commands Enables you to reuse and manage saved commands. A com-

mand is any action that you take in Flash, such as drawing or
editing objects. You can save commands from the History panel.
(See Chapter 4.)

Control Provides options that let you control the playing of movies; test
movies and scenes; engage certain interactive functions; and
mute sounds.

Window Enables you to open lots of things, including a new window;
panels that help you control objects; the Library (more on the
Library in Chapter 2); windows for creating interactive controls
(which we explain in Chapter 10); and the Movie Explorer (to
help manage your movie — see Chapter 12).

Help Comes to the rescue when you need help.

Many menu commands offer keyboard shortcuts. You can also create your
own keyboard shortcuts. (See Appendix A for instructions.)

The shortcuts are displayed on the menus, next to the command name. Here
are some of the most commonly used keyboard shortcuts (for more short-
cuts, see the tear-out Cheat Sheet at the front of this book):

v Ctrl+N (Windows) or 38+N (Mac): Open the New Document dialog box so
you can start a new movie.
1 Ctrl+O (Windows) or 8+0 (Mac): Open an existing movie.

v Ctrl+S (Windows) or 38+S (Mac): Save your movie. Use this shortcut
often!

17
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v Ctrl+X (Windows) or 88+X (Mac): Cut to the Clipboard. Chapter 4
explains more about using the Clipboard.

v Ctrl+C (Windows) or 88+C (Mac): Copy to the Clipboard.
v Ctrl+V (Windows) or 88+V (Mac): Paste from the Clipboard.

v Ctrl+Z (Windows) or 38+Z (Mac): Undo. Would you believe that by
default Flash remembers your last 100 actions and can undo them? What
a relief! And if you choose Window=>Other Panels=>History, the History
panel lists each action, so you know what the next Undo will undo.
Think of it as a journey into the long-forgotten past. (See Chapter 4 for
more on the History panel, and see Appendix A for details on customiz-
ing the number of Undos that Flash remembers.)

v Ctrl+Y (Windows) or 38+Y (Mac): Redo. This redoes actions that you
undid by using the Undo button. (Got that?) This button remembers just
as many actions as the Undo button. If you undo more actions than you
want, click Redo (or press Ctrl+Y/8+Y) until you're back where you
want to be. Using the Undo and Redo buttons is like traveling through
Flash time — and it gives you lots of slack while you’re working.

v Ctrl+Q (Windows) or 38+Q (Mac): Exit Flash.

We mention other keyboard shortcuts throughout this book when we discuss
their corresponding commands.

You should note, although it’s not a shortcut, that you can find the Zoom
Control box in the upper-right corner of your screen — if you open the Edit
bar (choose Windowr>Toolbars=>Edit Bar). Click the arrow and choose a
zoom factor to zoom in and out. Zooming doesn’t change the actual size of
objects — it just makes them look bigger or smaller.

You aren’t limited to the choices on the Zoom drop-down list. Type a number in
the Zoom Control box and press Enter (Windows) or Return (Mac) to set your
own zoom factor. For example, type 85 to set the zoom factor to 85 percent.

Staging your movies

The white box in the center of your screen is the Stage. Think of the Stage as
a movie screen where you place objects. You can place graphics and text
there and then animate them. Flash also plays back movies on the Stage.

Around the edge of the Stage is a gray area called the Pasteboard. You can use
the Pasteboard to store graphics that you plan to use soon but don’t want on
the Stage just yet. (For more permanent storage, use the Library, as we explain
in Chapter 2.) You can also store data and other nongraphical content on the
Pasteboard. Content that you put on the Pasteboard doesn’t appear in your
Flash movie.
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Following a timeline

The Timeline window divides your movie into frames. Each frame represents
a tiny stretch of time, such as %: of a second. Creating a movie is simply a
matter of assembling frames, which are then quickly played in order.

Chapter 9 explains in detail how to make using the Timeline completely pain-
less. For now, you should just understand the basics. See Figure 1-2 for the
basic Timeline.
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On the left side of the Timeline is the layer list. When you open a new movie,
you see only one layer, unimaginatively named Layer 1. A layer is like a sheet
of transparent acetate on which you draw objects. Layers help you keep
objects from running into each other, causing unfortunate, messy results. You
organize your entire movie by using layers. For example, if you want to keep
some text constant throughout the movie but animate a bouncing dot, you
would give the dot its own layer and animate it on that layer. The layer list
has room for more layers, and you can add as many layers as you want.
(Chapter 6 gives you the lowdown on layers.)

You can lower the bottom edge of the Timeline to make room for more layers.
Hover the mouse cursor over the bottom line until you see the two-headed
arrow and drag downward.

To the right of Layer 1, you see a bunch of rectangles, each representing a
frame. (Actually, before you start using the Timeline, they’re just potential
frames, like unexposed frames on a roll of film.) By default, each frame lasts
Y2 of a second. Each layer has its own row of frames because you can have
different animations or objects on each layer.

A keyframe is a frame that defines some change in your animation. In some
animations, every frame is a keyframe. Other animations need keyframes for
only the first and last frames.

You don’t use the Timeline until you're ready to animate. While you work,
however, you should organize your objects on separate layers. Don’t worry —
you can always move an object from one layer to another.

19
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Getting Help in a Flash

This book is all that you need to start creating great animations, but we
would be remiss if we didn’t tell you about the Flash Help system.

To use Flash Help, choose Helpr>Flash Help. You see a window like the one
shown in Figure 1-3.
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Multiple Help manuals

Flash Help contains several sections:
v Getting Started with Flash contains a basic overview of Flash and creat-
ing a Flash movie.
v Flash Tutorials is an extensive set of tutorials.
v Using Flash is the main Help manual.

v~ Flash Samples contains some specific examples of Flash files, mostly of
advanced techniques.

v Learning ActionScript 2.0 in Flash is a user’s guide for ActionScript,
Flash’s programming language. (See Chapter 10 to find out more.)

1 ActionScript 2.0 Language Reference describes the components of the
ActionScript programming language.
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1+~ Using Components explains how to use components (did you guess?),
which we explain in Chapter 10. Components are basic Web interface ele-
ments, such as check boxes and forms that you can drop into your movie.

1 Components Language Reference contains a components dictionary.

v+ Extending Flash offers help for Flash programmers who want to extend
its capabilities.

+ Flash Lite Developer Guide explains how to use Flash Professional 8 to
develop Flash movies for mobile phones. Flash Lite is a version of the
Flash Player for mobile phones.

v Learning Flash Lite ActionScript is about the special version of
ActionScript for Flash Lite movies.

v~ Flash Lite 1.x ActionScript Language Reference is a programming refer-
ence for Flash Lite ActionScript.

To search for a term, click the Search button. Then enter the term and click
Search. You can choose one of the Help sections from the drop-down list to
focus your search more narrowly. You can then choose from the list of topics.

Finding more help on the Web

Macromedia offers support on its Web site. To access it, choose Help=>Flash
Support Center, which takes you to www.macromedia.com/support/flash.
There you can search the knowledge base and tutorials for answers to your
questions.

Try It; Vou'll Like It

Perhaps by now you're getting impatient to try out Flash. Getting started is
easy. You collect a few ideas, put together some art, add animation, save your
movie, and publish it. Then you view it in a browser either online or offline.
That’s the gratifying part. In the following sections, you get to try out Flash
by working through a basic animation. The rest of the book explains the basic
concepts in more detail.

Conceiving your first animation

Suppose that you want to add an animated logo to a home page that you've
already set up. You want the animation to run when the page loads and then
stop. Figure 1-4 shows the Rainbow Resources company logo — unanimated,
of course — that you can find on this book’s Web site, at www.dummies.com/
go/flashs8.
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Suppose that you want the word Rainbow to fly into your page from the right
and the word Resources to fly in from the left. At the same time, you want the
graphic to rotate 180 degrees. The following section shows you how to create
this animation.

Creating flashy drawings

You can use Flash to create a company logo, but importing one from this
book’s Web site is simpler. Often, you import existing graphics (such as a
company logo) from a file rather than create them from scratch. (Chapter 3
explains how to import and manipulate graphics.)

If you're going through the steps and make a mistake, choose Edit=>Undo (or
press Ctrl+Z/38+Z) and try again. You can use Undo repeatedly to undo sev-
eral steps, if necessary.

To import the Rainbow Resources logo into Flash, follow these steps. (The
steps might vary if you're importing some other graphic in a different format.)
1. Start Flash.

See the instructions in the section “Starting Flash on a PC” or “Starting
Flash on a Mac,” earlier in this chapter, if you need help.

2. Choose Flash Document from the Create New section of the Startup
screen.

You see a spanking-new movie on your screen.

3. Go to www.dummies.com/go/£flash8 and download the rainbow.gif
file.

4. Choose File=> Import->Import to Stage.
The Import dialog box opens.
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. Browse the dialog box until you find rainbow.gif in the location

where you downloaded it.

. Click to select rainbow.gif and then click Open.

If you have difficulty importing the file, copy it to your hard drive and
try Steps 3-5 again.

You see the logo on your screen. You need to break the logo into
pieces and make it a vector graphic so that you can animate sections
of it separately.

. Choose Modify~>Bitmap>Trace Bitmap.

The Trace Bitmap dialog box appears.

. In the Trace Bitmap dialog box, set the color threshold to 100, the

minimum area to 1, the curve fit to Pixels, and the corner threshold
to Many Corners. Click OK in the Trace Bitmap dialog box.

In our example, we chose to use settings that reproduce the bitmap as
faithfully as possible. Flash creates a vector graphic and breaks up the
graphic into individual components. The entire graphic, however, is
selected.

Click anywhere outside the graphic to deselect it.

You've got your logo! Now you need to set it up for animation.

Turning your objects into symbols

In the logo that you imported in the preceding section, each letter is a sepa-
rate object, which can get pretty confusing. Each line in the logo’s design is
also separate. But you want your words to stay together — and the little
design, too. So you must combine each word and the logo into a symbol. A
symbol helps keep objects together and is required for some kinds of anima-
tion. (See Chapter 7 for the scoop on symbols.)

To turn the words and the logo into symbols, follow these steps:

1.

2.

To get a better view of your image, click the Zoom Control drop-down
list (at the upper-right corner of the Stage area) and choose 200%.

If you don’t see the Zoom Control drop-down list, choose Window=>
Toolbars=>Edit Bar to display it.

Use the scroll bar to scroll the words of the logo into view, if necessary.

Click the Selection tool on the Tools panel if it’s not already selected.

23



24

Part I: A Blast of Flash

3. Click the upper-right corner of the word Rainbow (just above and to
the right of the w) and drag to the lower-left corner of the first letter, R.

Dragging from right to left makes it easier to avoid selecting the logo at
the same time. You should see the entire word selected. If not, click out-
side the word and try again.

4. Choose Modify=>Convert to Symbol. In the Convert to Symbol dialog
box, click Graphic for the behavior and then click OK.

It is normally good practice to name the symbol, but not necessary for
this exercise. When you click OK, Flash places a box around the word so
that you can see that it’s one object.

5. Repeat the procedure outlined in Steps 3 and 4 with the word
Resources.

In this case, you might want to start clicking and dragging from the
upper-left area of the word; then choose Modify=>Convert to Symbol
again and click OK. Now all the letters of the word Resources are a single
object.

6. Click the Zoom Control drop-down list and choose 100% so that you
can see the entire logo.

7. Click above and to the left of the logo and drag to the lower right to
select the entire logo.

8. Hold down the Shift key and click each word to remove both words
from the selection.

Now the design portion of the logo is selected.

9. Press F8 (the keyboard shortcut to create a symbol) and click OK in
the Convert to Symbol dialog box.

Flash creates a symbol from the lines of the logo’s design.

See Chapter 7 to find out more about what symbols are and how to use them.
Symbols are important building blocks in Flash movies.

Putting your graphics on layers

You need to place different pieces on different layers when you’re animating.
You use layers to organize your movie and keep shapes separate so that they
don’t interfere with each other. (See Chapter 6 for the complete story on
layers.)

To split your three symbols onto three separate layers, you can use a conve-
nient feature of Flash 8: Distribute to Layers. Follow these steps:
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1. Click the Selection tool on the Tools panel if it’s not already selected.

2. Drag diagonally across the entire logo, including the two words, to
select it.

You should see two rectangles inside one bigger rectangle. All three
objects in the logo are selected.

3. Choose Modify~ Timeliner>Distribute to Layers.

You now have three new layers, named from Symbol 1 through Symbol 3.
The three objects of the logo have been distributed to Symbol 1 through
3 and removed from Layer 1.

4. Click outside the Stage to deselect any objects and choose 100% from
the Zoom Control drop-down list.

You're now ready for the animation process.

Making graphics move

We explain earlier in this chapter that your goal is to have the word Rainbow
fly in from the right and the word Resources to fly in from the left. You also
want the graphic to rotate 180 degrees at the same time. What you see now is
how the animation will end — the last frame of the movie.

Follow these steps to create the last frame of the movie and save the file:
1. For each of the three symbol layers, click frame 30 of the Timeline
and choose Insert~> Timeline>Keyframe.

You can find out more about keyframes in Chapter 9.

2. Choose File>Save and pick a location where you save other docu-
ments that you create.

We don’t recommend saving the file in the Flash 8 program folder — it
might get lost among your Flash program files.

3. Give your movie a name, such as Movie of the Year, and click Save.
Flash creates a file named Movie of the Year.fla.Flash adds .fla
for you because that’s the filename extension for Flash movies.

Go back and create the beginning of your movie. Flash can fill in all the
blanks in between. Follow these steps to create the beginning of the movie
and the animation:
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10.

11.

. If the Property inspector isn’t already open, choose Window=>

Properties=>Properties to open it.

If the Property inspector is open but collapsed, click the arrow at the left
end of its title bar to expand the panel.

. Select the word Rainbow. Click the first frame of the Timeline in the

highlighted row.

When you select the word Rainbow, you can tell which layer it is on by
looking at the highlighted layer.

. Press and hold down the Shift key while you drag the word to the

right, just off the Stage into the gray area.

You might need to use the horizontal scroll bar or choose a lower zoom
percentage from the Zoom drop-down list to see the gray area. Pressing
Shift keeps the object from moving up or down while you drag to the
right. By clicking the first frame and moving the word, you set its posi-
tion at the beginning of the animation.

. Click the word Rainbow’s layer, anywhere between the first and the

30th frame.

. On the Tween drop-down list of the Property inspector, choose

Motion.

You now see a solid arrow and a light blue color on the Timeline between
the first and 30th frames. Choosing Motion from the Tween drop-down list
creates animation that moves the symbol from the position in the first
frame to its position in the next keyframe, which is frame 30 in this movie.

. Repeat Steps 2—4 for the word Resources. When you move the word

Resources, hold down the Shift key and drag the word to the left, just
off the Stage.

. Select the logo design and click the first frame of the Timeline in the

highlighted row.

. Choose Modify= Transform=>Rotate 90° CW to rotate the design 90

degrees clockwise.

. Repeat the Modify~> Transform=>Rotate 90° CW command to rotate the

design a total of 180 degrees.

Click the logo’s highlighted layer, anywhere between the first and
30th frames, and choose Motion from the Tween drop-down list of the
Property inspector.

If necessary, drag the horizontal scroll box until the Stage is in the
center of your screen.

Otherwise, you won’t be able to see the entire animation — and you
don’t want to miss this one!
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12. Click the first frame of any layer.
Your screen should look like the one shown in Figure 1-5.

13. Press Enter (Return) and watch the animation. (Start writing your
Academy Awards acceptance speech.)

14. Save your movie again by choosing File~>Save.

Publishing your first animation
for posterity

You can’t watch the animation in a Web browser until you publish it and
insert it into an HTML document. To do so, follow these steps:
1. Click the Stage to change the display of the Property inspector.
You should see the Settings button next to the Publish label.
2. Click the Settings button in the Property inspector.
The Publish Settings dialog box opens.
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3. Click the HTML tab.

4. Deselect the Loop check box in the Playback section.

We want the animation to play only once.

. Click the Publish button and then click OK to close the dialog box.

With scarcely a blip, Flash publishes your movie and creates two files,
one named Movie of the Year.swf (assuming you used that name)
and Movie of the Year.html. They're in the same folder as your .fla
movie file. Movie of the Year.swf is the file that your browser reads
to play the animation. Movie of the Year.html contains the HTML
code required to display your movie on a Web page.

6. Open your Web browser.

7. Choose File=>Open (or Open File) and find Movie of the Year.html

10.

(or whatever you named your movie file).

You might need to click Browse and navigate to the file.

. Double-click the file.

Your browser opens the HTML document and reads its instructions to
play the Flash movie.

. Sit back and watch it roll.

Don’t blink or you’ll miss it. (If you do miss it, click the Refresh or
Reload Current Page button in your browser.) You can see the movie
in Figure 1-6.

When you finish watching the movie, close your browser.

You can find the Movie of the Year files (. f1a, .html, and . swf) in the Ch01
folder on this book’s Web site, www . dummies.com/go/flashs.

Exiting Flash

When you finish creating something in Flash, choose File>Exit (Windows) or
choose Flashe>Quit (Mac).
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]
Figure 1-6:
The Movie
of the Year

animation in

detail.
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Chapter 2
Your Basic Flash

In This Chapter

Examining the big picture
Setting movie properties
Getting graphics

Using templates

Printing your movie

' his chapter starts with an overview of the process of creating animation
in Flash. We then discuss some tools and features that are fundamental to
using Flash efficiently.

As you find out in this chapter, you use movie properties to set the screen
size and color, frame rate, and measurement units for the Flash movie as a
whole. We also discuss the Library and how it’s a storehouse for images, sym-
bols, and sound. Templates enable you to create great movies without much
work. Finally, near the end of this chapter, we explain how you can print a
Flash movie.

Looking at the Big Picture

When you use Flash to create animation for your Web site, you generally go
through several steps of construction. The steps might vary in their order,
depending on your situation. After you know the basics, you can start getting
creative and make your Web site rock. Here’s a typical path to add animation
to an existing Web page:

1. Think about it. Noodle around, maybe make some doodles on a napkin,
collect a few ideas, and choose one or all of them.

2. Set up your movie. Flash lets you choose the size and color of the Stage,
the speed of animation (number of frames per second), and other gen-
eral parameters that affect the entire Flash movie. See the next section
of this chapter for details.



